1. Welcome to Thailand Vapers, an English language forum for members in Thailand and the rest of Asia to talk about vaping.
    Commonly referred to as e-cigarettes, vaping is really about the use of personal vaporizers (mods) and atomizers (tanks, clearos, RBAs, RDAs, RTAs) filled with e-liquid.
    Are you looking to get started or an old hand at vaping? Everyone is welcome here so sign up today and talk vaping with us!

Help New Wismec RX200 won't turn on

Discussion in 'Vaping Technical Issues' started by Bardolf, Mar 14, 2020.

Tags:
  1. Bardolf

    Bardolf Thread Starter New Member

    Joined:
    Apr 9, 2017
    Messages:
    12
    Likes Received:
    0
    Location:
    Samut Prakan
    So my trusty iJoy Maxo Quad has finally given up the ghost it has been my daily use mod for over 3 years so it has had a good run :) While looking around for a replacement I came across a supplier with the Wismex Reuleaux RX200 on special. Now I know it is an outdated mod but back when I bought the Maxo I was tossing up between that and the RX200 so I figured this was a sign to give the RX200 a try.

    The unit arrived still sealed in plastic with the security sticker unscratched so I'm guessing it is really a "new" device but when I put my batteries in I can't get it to turn on. I have 4x Sony VT6s and 2x AWT 3000mah. Now I have tried all 4 of the Sony batteries in different locations in the device and also tried the 2 AWTs with a single Sony as well.

    I'm hoping there is some silly thing I am overlooking, has anyone had one of these before and if so any ideas?
     

Share This Page