Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 7 of 7

Thread: IClear 30 dry hit

Share                     
    Bookmark and Share
  1. #1
    Thai E-Vape Member

    Anbessa's Avatar
    Join Date
    Apr 2013
    Last Online
    11th May 2014 @ 05:10
    Posts
    376

    IClear 30 dry hit

    Yesterday i got a very dry hit from the iClear 30 tank and i was mad as hell.The juice was still around 2ml and i tilted the tank as well so i did not understand why.
    I did refill the tank and first it was ok again but After a few Vapes, bang, again, so bad it almost made me trow up and the dry hits kept on continuing.
    A couple day's ago i replaced the atomizer and noticed the wicks are different,not so thick and of a different material, could this be the cause? It seemed to me the coils are not proper fed with juice from the wicks.
    I have cleaned my old atomizer via dry burn and so far it works normal again.

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many
     

  3. #2
    Forum Troll

    spacemunk's Avatar
    Join Date
    Jan 2013
    Last Online
    9th August 2014 @ 20:30
    Location
    Prawet
    Posts
    596

    Re: IClear 30 dry hit

    normally with wicks , all you have to do is dry burn afew times and will be good as new.

    dry hits are always caused due to bad wicking

  4. Thanks Anbessa thanked for this post
  5. #3
    Admin
    This is -V-'s Country Flag

    -V-'s Avatar
    Join Date
    Jan 2012
    Last Online
    Today @ 13:07
    Posts
    5,044

    Re: IClear 30 dry hit

    Yes I noticed some of my replacement heads are different than others, I got a few from different vendors..
    Never had your problem though.
    Although I have had a few bad coils, not enough vapour as one of the coils wasn't working right....

    It's always going to be hit and miss with Chinese QC....


  6. #4
    Thai E-Vape Member

    Anbessa's Avatar
    Join Date
    Apr 2013
    Last Online
    11th May 2014 @ 05:10
    Posts
    376

    Re: IClear 30 dry hit

    So far the coil which original came with the tank works good after i put it back on.The wicks really seem to transport the juice much better....
    I have read to loosen the wick and to modify the silicon cap siting on top of the coil shaft by cut the end a bit to get better juice flow.Will see how that gos.

  7. #5
    Thai E-Vape Member

    colind88's Avatar
    Join Date
    Dec 2012
    Last Online
    Yesterday @ 18:29
    Posts
    204

    Re: IClear 30 dry hit

    Couple of other things you might check
    Make sure the new wick post is screwed in tight.
    Make sure the bottom pin on the iclear is extended out a little(it has a habit of slipping back in providing uneven power to the the coils)


    Quote Originally Posted by spacemunk View Post
    normally with wicks , all you have to do is dry burn afew times and will be good as new.

    dry hits are always caused due to bad wicking

  8. Thanks Anbessa thanked for this post
  9. #6
    Thai E-Vape Member

    Anbessa's Avatar
    Join Date
    Apr 2013
    Last Online
    11th May 2014 @ 05:10
    Posts
    376

    Re: IClear 30 dry hit

    Quote Originally Posted by colind88 View Post
    Couple of other things you might check
    Thanks for the tip's colind88 will have a look on this next time i replace the coil.

  10. #7
    Thai E-Vape Member

    Anbessa's Avatar
    Join Date
    Apr 2013
    Last Online
    11th May 2014 @ 05:10
    Posts
    376

    Re: IClear 30 dry hit

    After my original coil died yesterday, i took a look on the replacement again.I cut out the edges of the silicon cap which didn't do the trick. I also noticed a couple air bubbles were rising from the bottom of the tank and i had juice leaking from the air hole.Dry burning did not help either.
    Dry hit's and gurgling again and i was thinking why is it the the wicks just don't transport the juice.......

    I took the old coil apart and used the center pin to replaced the one from the new coil. I trimmed the wicks and unfolded them.
    Now the tank works like a charm, i get good vapor,taste and troth hit again just like before so i figure it's not the wicks or silicone cap which reduces the juice flow.

    My conclusion is the center pin of the coil was the problem and was not tighten up correctly,that caused the leaking and air bubbles in the tank.Is it maybe the vacuum in the tank if everything is sealed correctly and lets the wicks transport the juice better when you take a draw....?

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •